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1. Introduction to GeoGebra’s Spreadsheet View 
The dynamic mathematics software GeoGebra provides three different views of 
mathematical objects: a Graphics View, a, numeric Algebra View and a 
Spreadsheet View. They allow you to display mathematical objects in three 
different representations: graphically (e.g., points, function graphs), algebraically 
(e.g., coordinates of points, equations), and in spreadsheet cells. Thereby, all 
representations of the same object are linked dynamically and adapt 
automatically to changes made to any of the representations, no matter how they 
were initially created. 
 

 
 

Geometric Constructions 
Using the construction tools available in the Toolbar you can do geometric 
constructions in the Graphics View with the mouse. Select any construction tool 
from the Toolbar and read the Toolbar Help (next to the Toolbar) in order to find 
out how to use the selected tool. Any object you create in the Graphics View also 
has an algebraic representation in the Algebra View. 
 
Note that you are able to move objects in the Graphics View by dragging them 
with the mouse. At the same time, their algebraic representations are 
dynamically updated in the Algebra View. 
 
Every icon in the Toolbar represents a Toolbox that contains a selection of 
similar construction tools. In order to open a Toolbox, you need to click on the 
small arrow in the lower right corner of the Toolbar icon.  

Algebra 
View 

Graphics View 

Spreadsheet 
View 

Input Bar

Toolbar 
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Hint: Construction tools are organized by the nature of resulting objects or their 
functionality. You will find tools that create different types of points in the Point 
toolbox (default icon ) and tools that allow you to apply geometric 
transformations in the Transformation toolbox (default icon ). 

Algebraic Input and Commands 
Using the Input Bar you can directly enter algebraic expressions in GeoGebra. 
After hitting the Enter-key your algebraic input appears in the Algebra View while 
its graphical representation is automatically displayed in the Graphics View. For 
example, the input f(x) = x^2 gives you the function f in the Algebra View and 
its function graph in the Graphics View. 
 
In the Algebra View, mathematical objects are organized as free or dependent 
objects. If you create a new object without using any other existing objects, it is 
classified as a free object. If your newly created object was created by using 
other existing objects, it is classified as a dependent object.  
Hint: If you want to hide the algebraic representation of an object in the Algebra 
View, you can specify the object as an Auxiliary Object: Right click (MacOS: 
Ctrl-click) on the corresponding object in the Algebra View and select ‘Auxiliary 
Object’ from the appearing context menu. By default, Auxiliary Objects are not 
shown in the Algebra View, but you can change this setting by selecting the item 
‘Auxiliary Objects’ from the View menu. 
 
Note that you are able to modify objects in the Algebra View as well: Make 
sure that you activate the  Move tool before you double click on a free object in 
the Algebra View. In the appearing textbox you can directly edit the algebraic 
representation of the object. After hitting the Enter-key, the graphical 
representation of the object will automatically adapt to your changes.  
If you double click on a dependent object in the Algebra View, a dialog window 
appears allowing you to redefine the object.  
 
GeoGebra also offers a wide range of commands that can be entered into the 
Input Bar. You can open the list of commands in the right corner of the Input Bar 
by clicking on the button Command. After selecting a command from this list (or 
typing its name directly into the Input Bar) you can press the F1-key to get 
information about the syntax and arguments required to apply the corresponding 
command. 

Spreadsheet Cells Input 
In GeoGebra’s Spreadsheet View every cell has a specific name that allows you 
to directly address each cell. For example, the cell in column A and row 1 is 
named A1.  
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Note: These cell names can be used in expressions and commands in order to 
address the content of the corresponding cell. 
 
In the spreadsheet cells you can enter not only numbers, but all types of 
mathematical objects that are supported by GeoGebra (e.g., coordinates of 
points, functions, commands). If possible, GeoGebra immediately displays the 
graphical representation of the object you enter into a spreadsheet cell in the 
Graphics View as well. Thereby, the name of the object matches the name of the 
spreadsheet cell used to initially create it (e.g., A5, C1). 
 
Note: By default, spreadsheet objects are classified as Auxiliary Objects in the 
Algebra View. You can show or hide these Auxiliary Objects by selecting 
‘Auxiliary Objects’ from the View menu. 

Customize the User Interface and Toolbar 
The user interface of GeoGebra can be customized by using the View menu. 
For example, you can hide different parts of the interface (e.g., the Algebra View) 
by unchecking the corresponding menu item in the View menu (e.g., ‘Algebra 
View’). 
Note: In this way, you can also show or hide the coordinate axes and a 
coordinate grid. 
 
The Toolbar can be customized by selecting ‘Customize Toolbar…’ from the 
Tools menu. Highlight the tool or toolbox you want to remove from the Toolbar in 
the list on the left hand side of the appearing dialog window and click button 
‘Remove >’ in order to remove the tool/toolbox from the Toolbar. You can restore 
the default Toolbar by clicking on the button ‘Restore Default Toolbar’ in the left 
lower corner of the dialog window. 

2. Record to Spreadsheet Feature 

Preparations 

• Open a new GeoGebra file. 
• Show the Spreadsheet View (View menu). 
• Hide the Algebra View (View menu). 
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Instructions 

1  Create a slider with default interval and increment 1. 

  
Hint: Select tool Slider and click in the Graphics View to set 
the position for the slider. In the appearing dialog window 
change the increment to 1 and click the Apply button. 

2 A = (a, 2a) Create point A by entering A = (a, 2a) into the Input Bar. 

  Hint: The value of slider a determines the x-coordinate of 
point A while the y-coordinate is a multiple of this value. 

3  Show the label of point A in the Graphics View. 

4  
Change the value of slider a to examine different positions of 
point A. 

5  

 

Use tools Move Drawing Pad, as well as Zoom In and Zoom 
Out to adjust the visible part of the Graphics View and make 
point A visible in all positions. 



 

GeoGebra Workshop Handout   
 

 

 6

6  Turn on the trace of point A. 

  Hint: Right click (MacOS: Ctrl-click) on point A and select 
‘Trace On’ from the appearing Context Menu. 

7  
Change the value of slider a to examine the trace point A 
leaves for every slider position. 

8  Set the value of slider a to -5. 

9  
Record the coordinates for different positions of point A to 
the spreadsheet: 

  

(1)  Select tool Record to Spreadsheet. Then, click on 
 point A in order to highlight it.  
       Note: The coordinates for the actual position of point 
 A are immediately entered into cells A1 (x-coordinate) 
 and B1 (y-coordinate) of the spreadsheet. 
(2)  Now, change the value of slider a in order to record 
 the coordinates of all other possible positions of point 
 A to the spreadsheet as well. 
 Note: Do not switch to another tool before moving the 
 slider. 

Additional Tasks  

Task 1: Examine the pattern of y-values in column B 
You could give this construction to your students and let them explore the pattern 
in column B, which is created by the y-coordinates of different positions of point 
A. Encourage your students to make a prediction about a function graph that 
runs through all different positions of point A. Have your students enter the 
corresponding function into the Input Bar in order to check whether their 
prediction was correct (e.g., students enter f(x) = 2x to create a line through 
all points). 

Task 2: Create a new problem  
Change the y-coordinate of point A in order to create a new problem:  

• Right click (MacOS: Ctrl-click) on point A and select ‘Properties…’ from 
the appearing Context Menu. 

• In tab ‘Basic’ you can change the y-coordinate of point A in the text field 
‘Definition’ to, for example, a^2. 

• Use the other tabs of the Properties Dialog in order to change the color 
(tab ‘Color’) or size (tab ‘Style’) of point A. 

• Close the Properties Dialog when you have made all desired changes. 



 

GeoGebra Workshop Handout   
 

 

 7

• Repeat steps 7 to 9 of the instructions above in order to record the 
coordinates of the new positions of point A to the spreadsheet.  
Note: If you did not delete the old values in columns A and B, GeoGebra 
automatically uses the next two empty columns (e.g., columns C and D) in 
order to record the new values for x-coordinates and y-coordinates. 

3. Relative Copy and Linear Equations 

Preparations 

• Open a new GeoGebra file. 
• Show the Spreadsheet View (View menu). 
• Hide the Algebra View (View menu). 
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Instructions 

1  
Activate tool Move Drawing Pad and drag the origin of the 
coordinate system close to the lower left corner of the Graphics 
View. 

2 (0, 0) In the Spreadsheet View, click on cell A1 and enter the point 
coordinates (0, 0).  

3 (1, 1) In the Spreadsheet View, click on cell A2 and enter the point 
coordinates (1, 1). 

4 
 

Select tool Show/Hide Label and show the labels of both points 
in the Graphics View. 

5  
Relative copy the inserted point coordinates to other cells in 
column A:  

  

(1)  Highlight both cells A1 and A2 by using the mouse.  
(2)  Click on the little square at the lower right corner of the 
 highlighted cell range.  
(3)  Hold the mouse button down and drag the pointer down 
 to cell A11. 

6  

 

Use tools Move Drawing Pad, as well as Zoom In and Zoom 
Out to adjust the visible part of the Graphics View and make all 
points visible. 

Additional Tasks 

Task 1: Examine the coordinates of the point sequence 
What sequence of numbers is created if you apply the ‘relative copy’ feature of 
the GeoGebra spreadsheet the way it is described above? 
Hint: Examine the x-coordinates of all created points and come up with a 
conjecture about how they are related. Then, check your conjecture using the y-
coordinates of the points. 

Task 2: Find the matching equation 
Make a prediction about an equation that would create a graph going through all 
points of this sequence. Enter this equation into the Input Bar in order to check 
your prediction. 
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Task 3: Create a new problem 
Change the coordinates of the initial points in order to create a sequence of 
points that can be examined by your students. 
 
Version 1: Change the initial points in the Spreadsheet View. 
Double click in cell A2 and change the coordinates of the corresponding point to 
(1, 2). After hitting the Enter-key, all points that depend on point A2 
automatically adapt to this change, both in the Spreadsheet View as well as in 
the Graphics View. 
 
Version 2: Change the initial points in the Graphics View. 
Activate tool  Move and drag point A2 to a different position in the coordinate 
system. Immediately, all dependent points dynamically adapt to these changes 
both in the Graphics View as well as in the Spreadsheet View. 
Note: In order to restrict the coordinates of the points to be integers, you can 
change the option ‘Point Capturing’ in the Options menu to ‘On (Grid)’. You may 
also display the coordinate grid by selecting ‘Grid’ from the View menu. 
 
Hint: By changing the coordinates of point A1 as well, you are able to create 
problems that result in linear equations of the form y = m x + b which do not run 
through the origin of the coordinate system. 

4. Investigating Number Patterns 
Let’s investigate how the surface of a cube changes depending on the length of 
its edges. 

Preparations with Paper and Pencil 

Calculate the surface of a cube for the given length e of its edges. Pick at least 
two edge lengths from each table but do not pick the same numbers as your 
neighbor. 
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Edge Surface

1

2

3

4

5
 

Edge Surface

6

7

8

9

10
  

Preparations in GeoGebra 

• Open a new GeoGebra file. 
• Show the Spreadsheet View (View menu). 
• Hide the Algebra View (View menu). 
• In the Options menu set the Labeling to ‘New Points Only’. 
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Instructions 

Create a Scatter Plot from your Data 

1  Enter the following numbers into the spreadsheet cells of column A: 
A1:  1   A2: 2 

2  Highlight cells A1 and A2. Relative copy the values to cell A10 in 
order to create a sequence of different edge lengths. 

  Hint: This creates the integers from 1 to 10. 

3  In column B, enter the surface values you calculated earlier next to 
the corresponding edge length of the cube. 

  Hint: You may collaborate with your neighbors to complete the table. 

4  Select cell B1 and relative copy the formula down to cell B10. 

5  Create a Scatter Plot from this data: 

  

(1)  Use the mouse to highlight all cells of columns A and B that 
 contain numbers. 
(2)  Right click (MacOS: Ctrl-click) on one of the highlighted cells 
 and select ‘Create List of Points’ from the appearing Context 
 Menu. 

  Note: The values in column A determine the x-coordinates and the 
values in column B specify the y-coordinates of the plotted points. 

  Hint: The points created from the data are displayed in the Algebra 
View as a list of points. By default, GeoGebra calls this list L1. 

6  
Use tool Move Drawing Pad in order to change the scale of the 
y-axis so that all points are visible in the Graphics View. 

  Hint: Select tool Move Drawing Pad. Click on the y-axis and drag it 
down until you can see the 600 tick mark. 

Investigate the Number Pattern in Column B 

7  In cell C2, enter the formula = B2 - B1 to compute the difference of 
the two successive surface values. 

  Hint: After entering the equal sign, you may click on cell B2 in order 
to enter its name into the active cell C2. 

8  Select cell C2 and relative copy the formula down to cell C10. 
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9  In cell D3, enter the formula = C3 - C2 to compute the difference of 
the two successive differences. 

10  Select cell D3 and relative copy the formula down to cell D10. 

Task 1 
Examine the number sequences in columns C and D. Make a conjecture about 
the polynomial function that runs through all points plotted in the Graphics View 
and allows you to compute the surface of a cube for any given edge length e. 

• Is it possible to determine the degree of this polynomial by investigating 
the sequences of differences you generated in columns C and D? 

• Explain to your neighbor why we were repeatedly calculating differences 
of successive values and what they actually mean. 

• Is it possible to determine the coefficient of the polynomial by investigating 
the sequences of differences you generated in columns C and D? 

• Would this also work if the values in column A are not successive integers 
(e.g., 1, 3, 5,…)? Explain your answer. 

Check your Conjecture about the Polynomial 

11  
Create a slider n with interval from 0 to 5 and increment 1. Change 
the orientation of the slider from ‘Horizontal’ to ‘Vertical’. 

12  
Create a slider a with interval from -5 to 5 and increment 1. Change 
the orientation of the slider from ‘Horizontal’ to ‘Vertical’. 

13  Enter the polynomial f(x) = a * x^n in order to create a 
polynomial of degree n with coefficient a. 

  Note: Both, the degree n as well as the coefficient a can be changed 
by using the corresponding sliders. 

14  
Change the values of sliders a and n to match your conjecture. Does 
the polynomial run through all points plotted in the Graphics View? 

Enhance your Construction 

15  
Insert the polynomial’s equation as a dynamic text in the Graphics 
View. 

  

Hint: Select tool Insert Text and click on the Graphics View to open 
the text edit dialog window. 
(1)  Enter f(x)= into the text edit dialog window. 
(2)  Click on the graph of the polynomial to insert it’s name into the 
       text edit dialog window.  
       Note: GeoGebra will enter the syntax necessary for dynamic 



 

GeoGebra Workshop Handout   
 

 

 13

 text automatically. 
(3)  Click on the OK button. 

16  
Insert a checkbox that allows you to show/hide the polynomial’s 
equation. 

  

Hint: Select tool Checkbox to Show/Hide Objects and click on the 
Drawing Pad to open the checkbox dialog window. 
(1)  Enter the caption Show equation. 
(2)  Click on the little arrow to open list of available objects.  
(3)  Select text1 from this list and click the ‘Apply’ button. 

17  
Activate the Move tool and try out if your checkbox controls the 
visibility of the text. 

18  
Open the Properties Dialog and enhance the layout of the objects in 
the Graphics View (e.g., change the color of the polynomial and the 
points, match the color of the text with the color of the polynomial, fix 
the position of the slider, checkbox, and text in the Graphics View).   

Task 2 
• Try if this concept of investigating sequences of differences of two 

successive function values works for all polynomials f(x) = a xn.  
Hint: You may enter a formula into cell B1 and relative copy it down to cell 
B10 in order to create a list of function values. Don’t forget to start the 
formula with an equal sign (e.g., = x^2) 

• What modifications in the Spreadsheet View and Graphics View are 
necessary to be able to easily determine the constant of polynomials  
f(x) = a xn + b? 

5. Scatter Plot and Best Fit Line 

Preparations 

• Open a new GeoGebra file. 
• Show the Spreadsheet View (View menu). 
• Hide the Algebra View (View menu). 
• In the Options menu set the Labeling to ‘New Points Only’. 
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Instructions 

1  Enter the following numbers into the spreadsheet cells of column A:
A1:  1  A2: 5 A3:  2 A4:  8 A5: -2 

2  Enter the following numbers into the spreadsheet cells of column B:
B1:  -1  B2:  2  B3:  3 B4:  4 B5:  1 

3  Create a Scatter Plot from this data: 

  

(1)  Use the mouse to highlight all cells of columns A and B that 
 contain numbers. 
(2)  Right click (MacOS: Ctrl-click) on one of the highlighted cells 
 and select ‘Create List of Points’ from the appearing Context 
 Menu. 

  Note: The values in column A determine the x-coordinates and the 
values in column B specify the y-coordinates of the plotted points. 

4  
Use tool Best Fit Line in order to create the line that best fits your 
data points. 

  

Hint: Activate tool Best Fit Line and select all data points using a 
selection rectangle: Click in the upper left corner of the Graphics 
View. Hold the mouse key down while moving the pointer to the 
lower right corner of the Graphics View in order to specify the 
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selection rectangle. 

5  Change color and thickness of the line using the Properties Dialog. 

6  Using this construction you can easily demonstrate how outliers 
impact the best fit line of a data set: 

  
Drag one of the points with the mouse and explore how this 
modification influences the best fit line. 

  Note: You can easily change the initial data in the Spreadsheet 
View as well. 

Importing Data from other Spreadsheets 
Note: GeoGebra allows you to copy and paste data from other spreadsheet 
software into the GeoGebra spreadsheet: 

• Select and copy the data you want to import (e.g., use the keyboard 
shortcut Ctrl-C in order to copy the data to your computer’s clipboard).  
Note: You need to press both keys (e.g., Ctrl-key and C-key) at the same 
time in order to apply a keyboard shortcut. 

• Open a GeoGebra window and show the Spreadsheet View. 
• Click on the spreadsheet cell that should contain the first data value. 
• Paste the data from your computer’s clipboard into GeoGebra’s 

Spreadsheet View. In order to do so, you can either use the keyboard 
shortcut Ctrl-V or right click (MacOS: Ctrl-click) on the highlighted cell and 
select  Paste from the appearing Context Menu. 

6. Exploring Basic Statistics Commands 
Yesterday, you gave a mathematics quiz to the 25 students of your 1st period 
math class. After the quiz, you asked your students to rate the difficulty of the 
quiz on a scale from 1 (‘very easy’) to 5 (‘very difficult’).  

• 4 of your students rated the quiz ‘very easy’ (1)  
• 6 students rated the quiz ‘easy’ (2) 
• 6 other students rated the quiz ‘difficult’ (4)  
• 1 student rated the quiz ‘very difficult’ (5) 
• The rest of the students thought the difficulty of the quiz was ‘ok’ (3). 

Preparations 

• Open a new GeoGebra file. 
• Show the Spreadsheet View (View menu). 
• Show the Algebra View (View menu). 
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• Drag the origin of the coordinate system to the lower left corner of the 
Graphics View using tool  Move Drawing Pad. 

 

Task 1: Create a Histogramm 

Enter the data into GeoGebra’s spreadsheet and create a histogram.  
 

 

Instructions 

1 Enter the rating scores from 1 to 5 into column A of the spreadsheet, 
starting in cell A2. 

2 Enter the number of students who rated the quiz with each score into 
column B of the spreadsheet, starting with cell B2. 

3 

Enter the class boundaries (starting and ending values of the histogram bar 
widths) into column C, starting in cell C1. Make sure that the histogram bars 
are drawn symmetrically around the rating scores (i.e., numbers from 1 to 5 
on the x-axis). 

 

Hints: 
• The first bar is supposed to be symmetrically drawn around the x-

value 1. Therefore, the bar should start at 0.5 and end at 1.5. 
• Enter the value 0.5 in cell C1 and the value 1.5 into cell C2. 
• Relative copy these two values down to cell C6. This creates the 
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missing values 2.5, 3.5, 4.5, and 5.5. 

4 Create a list of numbers from the class boundary values in column C.  

 

(1)  Use the mouse to highlight all cells of columns A and B that  contain 
 numbers. 
(2)  Right click (MacOS: Ctrl-click) on one of the highlighted cells 
 and select ‘Create List’ from the appearing Context Menu. 
 Note: In the Algebra View, the list L1 = {0.5, 1.5, 2.5, 3.5, 4.5, 5.5} is 
 displayed. 

5 Create a list of numbers (L2) from the values in column B. 

6 Create a histogram using the command Histogram[L_1, L_2] with L1 
and L2 being the two lists of numbers you created in steps 4 and 5. 

Task 2: Determine mean, median, and mode 

1. Make a prediction for mean, median, and mode of the data you collected. 
Hint: You may use command Sort[L_2] in order to sort the list of 
frequencies of students who rated the difficulty of the quiz in each 
category. 

2. Check your prediction using the commands Mean, Median, and Mode. 
Hint: If you don’t know how to use these commands, just enter the 
command into the Input Bar and press the F1 key in order to access the 
Input Bar Help. 

 
 


